运城天气,想要赚钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法

国际新闻 · 2019-04-01

许多人都在贴吧以及群里吐槽Total Control的脚本难用,易用性太差。我觉得这点TC的确应该检讨一下,究竟软件运用者许多都不是脚本把握很好的开发人员。可是Total Control 真是一款奇特的软件,有了它,不只可以用脚本完成主动翻开装置卸载手机软件等功用,还可以用脚本完成在多个手机上一起主动翻开卸载手机上的软件。


我今日就来共享一下用其他的脚本言语的运用实例。想用脚本完成装置卸载手机软件,是不是很高档,可是我不会JavaScript 怎么办?不要紧,Total Control 供给的 REST API 支撑恣意言语,易言语,python,java,都可以的哦!要完成在多个手机上一起翻开、封闭指定应用程序,首要咱们得用电脑衔接多个手机,然后运用 Total Control 供给的 REST API 操控手机,运用Total Control REST尔丰助力车 API 的一般过程:

1. 获取 Total Control 脚本开发所用的开发 token

2. 获取多个设备 ID 值,例如:{"ids":["device@33254183","device@230441652"]}

3. 经过第二步的多个设备 ID 值(多设备),对获取的设备进行操作

(一) Total Control 供给的REST API 获取多台设备 ID 调集的办法:

1. 获取一切设备 ID 调集

恳求办法:GET

恳求 URL:

http://127.0.0.1:8090/TotalControl/v1/devices?q=all&token=270eq7lXQK8bXYsJ

2. 依据给定的组称号获取组内一切设备 ID 调集

恳求办法:GET

恳求 URL:

http://127.0.0.1:8090/TotalControl/v1/devices?q=group&name=group1&token=270eq7lXQK8bXYsJ

3. 主动衔接设备,对当时准备好的设备主动衔接

请女教师疑现钏路市求办法:POST

恳求 URL:

http://127.0.0.1:8090/TotalControl/v1/devices/connections?token=270eq7lX运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法QK8bXYsJ

上杜小婷面三种获取设备 ID 调集的办法回来值如下:

{

"ids":[

"d日孕妈妈evice易友通物流单号查询@795844152",

"device@795812215"

]

}

(二) 易言语完成在多个手机上一起主动翻开软件

函数功用:翻开或运转设备上指定的软件

恳求方法:POST

http://IP:8090/TotalControl/v1/devices/:device/apps/:packageName?直播之盗墓天王state=active&token=:token

参数阐明:

易言语恳求实例:一起翻开多个手机上的微信,微信的软件名为 " com.tencent.mm"

代码如下:

.版别 2

.程序集 窗口程序集_发动窗口

.子程序 __发动窗口_创立完毕

.局部变量 base64, 文本型

.局部变量 token, 文本型

.局部变量 devices, 文本型

.局部变量 j_token, 类_json, , , 用来解析获取 token 的 json

.局部变量 j_dev, 类_json, , , 用来解析获取设备ID 值的 json

.局部变量 j_ret, 类_json, , , 用来解析 REST API 接口的json

.局部变量 bool, 逻辑型

.局部变量 bool_dev, 逻辑型

.局部变量 bool_ret, 逻辑型

.局部变量 AppName, 文本型

.局部变量 status, 文本型

.局部变量 数组成员, 类_json

base64 = 到文本 (编码_BASE64编码 (到字节集 (“sigma:3D391497”)))

输出调试文本 (“将用户名和暗码组装成 sigma:3D391497 进行 base64 编码生成的字符串为: ” + base64)

bool = j_token.解析 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/login”, 0, , , , “A圣蜜空气宝uthorization:” + base64, , , , , , , , , )))

.假如 (bool)

输出调试文本 (“第一步,获取 token,回来值为:” + j_token.取数据文本 ())

token = j_token.取通用特点 (“['value'].token”)

输出调试文本 (“获取的 token 值为: ” + token)

bool_dev = j_dev.解析 (编码_utf8到gb2312 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/devices?q=all&token=” + token, 0))))

.假如 (bool_dev)

输出调试文本 (“第二步,获取设备 ID 值,回来值为:” + j_dev.取数据文本 ())

devices = j_dev.取特点目标 (“ids”)

输出调试文本 (“获取的设备 ID 值为: ” + devices)

AppName = “com.tencent.mm”

bool_ret = j_ret.解析 (编码_utf8到gb2312 (到文本 (网页_拜访_目标 武力平(“http://localhost:8090/TotalControl/v1/devices/ids/apps/” + App运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法Name + “?state=activ运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法e&token=” + token + “&ids=” + devices, 1))))

.假如 (bool_ret)

输出调试文本 (“第三步,翻开手机” + devices + “上指定软件” + AppName)

输出调试文本 (“REST API 翻开指定软件的回来值为: ” + j_ret.取数据文本 ())

.不然

输出调试文本 (“该 API 履行失利”)

.假如完毕

.不然

输出调试文本 (“获取设备 ID 值失利”)

.假如完毕

.不然

输出调试文本 (“获取 token 失利”)

.假如完毕

运转成果:

* 将用户名和暗码组装成 sigma:3D391497 进行 base64 编码生成的字符串为: c2lnbWE6M0QzOTE0OTc=

* 第一步,获取 token,回来值为:{"status":true,"value":{"token":"ZEGpMU851z2CR45y"}}

* 获取的 token 值为: ZEGpMU851z2CR45y

* 第二步,获取设备 ID 值,回来值为:{"ids":["device@33254183","device@230441652"]}

* 获取的设备 ID 值为: ["device@33254183","device@230441652"]

* 第三步,翻开手机["device@33254183","device@230441652"]上指定软件com.tencen云亭应银河t.mm

* REST API 翻开指定软件的回来值为: [{"id":"device@33254183","code":200,"retval":{"status":true,"value":"make it active."}},{"id":"device@230441652","code":200,"retval":{"status":t马句和黄家驹对对比rue,"value":"make it active."}}]

(三) 易言语完成在多个手机上一起主动封闭软件

函数功用:封闭设备上指定的软件

恳求方法:POST

http://IP:8090/TotalControl/v1/devices/:device/apps/:packageName?state=inactive&token=:token

参数阐明:

易言语实例:一起封闭多个手机上的抖音小视频软件,抖音小视频的软件名为 "com.ss.android.ugc.aweme"

代码如下:

.版别 2

.程序集 窗口程序集_发动窗口

.子程序 __发动窗口_创立完毕

.局部变量 base64, 文本型

.局部变量 token, 文本型

.局部变量 devices, 文本型

.局部变量 j_token, 类_json, , , 用来解析获取 token 的 json

.局部变量 j_dev, 类_json, , , 用来解析获取设备ID 值的 js运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法on

.局部变量 j_ret, 类_json, , , 用来解析 REST API 接口的json

.局部变量 bool, 逻辑型

.局部变量 bool_dev, 逻辑型

.局部变量 bool_ret, 逻辑型

.局部变量 AppName, 文本型

.局部变量 status, 文本型

.局部变量 数组成员, 类_json

base64 = 到文本 (编码_BASE64编码 (到字节集 (“sigma:3D391497”)))

输出调试文本 (“将用户名和暗码组装成 sig运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法ma:3D391497 进行 base64 编码生成的字符串为: ” + base64)

bool = j_token.解析 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/login”, 0, , , , “Authorization:” + base64, , , , , , , , , )))

.假如 (bool)

输出调试文本 (“第一步,获取 token,回来值为:” + j_token.取数据文本 ())

token = j_token.取通用特点 (“['value'].token”)

输出调试文本 (“获取的 token 值为: ” + token)

bool_dev = j_dev.解析 (编码_utf8到gb2312 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/devices?q=all&token=” + token, 0))))

.假如 (bool_dev)

输出调试文本 (“第二步,获取设备 ID 值,回来值为:” + j_dev.取数据文本 ())

devices = j_dev.取特点目标 (“ids”)

输出调试文本 (“获取的设备 ID 值为: ” + devices)

AppName = “com.ss.android.ugc.aweme”

bool_ret = j_ret.解析 (编码_utf8到gb2312 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/devices/ids/apps/” + AppName + “?state=inactive&token=” + token + “&ids=” + devices, 1))))

.假如 (bool_ret)

输出调试文本 (“第三步天菜是什么意思,封闭手机” + devices + 伦理片97影视网“上指定软件” + AppName)

输出调试文本 (“REST API 封闭指定软件的回来值为: ” + j_ret.取数据文本 ())

.不然

输出调试文本 (“该 API 履行失利”)

.假如完毕

.不然

输出调试文本 (“获取设备 ID 值失利”)

.假如完毕

.不然

输出调试文本 (“获取 token 失利”)

.假如完毕

运转成果:

* 将用户名和暗码组装成 sigma:3D391497 进行 base64 编码生成的字符串为: c2lnbWE6M0QzOTE0OTc=

* 第一步,获取 token,回来值为:{"status":true,"value":{"token":"FTGyfvsaOmMP5j3g"}}

* 获取的 token 值为: FTGyfvsaOmMP5j3g

* 第二步,获取设备 ID 值,回来值为:{"ids":[苏妙龄"device@33254183","device@230441652"]}

* 获取的设备 ID 值为: ["device@33254183","device@230441652"]

* 第三步,封闭手机["device@33254183","device@230441652"]上指定软件com.ss.android.ugc.aweme

* REST API 封闭指定软件的回来值为: [{"id":"device@33254183","code":200,"retval":{"status":true,"value":"make it inactive."}},{"id":"device@230441652","code":200,"retval":{"status":true,"value":"make it inactive."}}]

(四) 不知道我要卸载的软件的软件包名怎么办?

为了便利用户,Total Control 供给了一个REST API来协助用户获取应用程序的包名。

函数功用:获取设备上当时运转的软件包名

恳求方法:GET

http://IP:8090/TotalControl/v1/devices/:device/apps?token=:token&q=foreground_app

参数阐明:

回来示例:

成功,则回来:

{

"status": true,

"value":"com.sigma_rt.totalcontrol"

}

易言语实例:获取设备上当时运转的软件包名

代码如下:

.版别 2

.程序集 窗口程序集_发动窗口

.子特茨翁程序 __发动窗口_创立完毕

.局部变量 base64, 文本型

.局部变量 token, 文本型

.局部变量 device, 文本型

.局部变量 j_token, 类_json, , , 用来解析获取 token 的 json

.局部变量 j_dev, 类_json, , , 用来解析获取设备ID 值的 json

.局部变量 j_ret, 类_json, , , 用来解析 REST API 接口的json

.局部变量 bool, 逻辑型

.局部变量 bool_dev, 逻辑型

.局部变量 bool_ret, 逻辑型

.局部变量 status, 文本型

base64 = 到文本 (编码_BASE64编码 (到字节集 (“sigma:3D391497”)))

输出调试文本 (“将用户名和暗码组装成 sigma:3D391497 进行 base64 编码生成的字符串为: ” + base64)

bool = j_token.解析 (到文本 (网页_运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法拜访_目标 (“http://localhost:8090/TotalControl/v1/login”, 0, , , , “Authorization:” + base64, , , , , , , , , )))

.假如 (bool)

输出调试文本 (“第一步,获取 token,回来值为:” + j_token.取数据文本 ())

token = j_token.取通用特点 (“['value'].token”)

输出调试文本 (“获取的 token 值为: ” + token)

bool_dev = j_dev.解析 (编码_utf8到gb2312 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/devices/main?token=” + token, 0))))

.假如 (bool_dev)

输出调试文本 (“第二步,获取设备 官子萱ID 值,回来值为:” + j_dev.取数据文本 ())

device = j_dev.取通用特点 (“['id']”)

bool_ret = j_ret.解析 (编码_utf8到gb2312 (到文本 (网页_拜访_目标 (“http://localhost:8090/TotalControl/v1/devices/” + device + “/apps?q=foreground_app&token=” + token, 0))))

.假如 (bo狐狸殿下txt下载ol_ret)

输出调试文本 (“第三步,获取当时运转的软件包名,回来值为: ” + j_ret.取数据文本 ())

status = j_ret.取特点目标 (“status”)

.假如 (stat刘良芳us = “true”)

输出调试文本 (“祝贺你,成功了!”)

.不然

输出调试文本 (“不好意思,失利了!”)

.假如完毕

.不然

输出调试文本 (“该 API 履行失利”)

.假如完毕

.不然

输出调试文本 (“获取设备 ID 值失利”)

.假如完毕

.不然

输出调试文本 (“获取 token 失利”)

.假如完毕

易言语代码运转成果:

成功,则回来:

* 将用户名和暗码组装成 sigma础组词:3D391497 进行 base64 编码生成的字符串为: c2lnbWE6M0QzOTE0OTc=

* 第一步,获取 token,回来值为:{"status":tr运城气候,想要挣钱创收 那就用脚本操作手机群控软件啊,香菇油菜的做法ue,"value":{"token":"U5孟东强6adwI779838M6F"}}

* 获取的 token 值为: U56adwI779838M6F

* 第二步,获取设备 ID 值,回来值为:{"id":"device@230441652"}

* 第三步,获取当时运转的软件包名,回来值为: {"status":true,"value":"com.sigma_rt.totalcontrol"}

* 祝贺你,成功了!

文章推荐:

app,我是大侦探,捣蛋猪-uwinapp_u赢app_u赢客户端

棚户区改造,妖猫传,郑州地铁-uwinapp_u赢app_u赢客户端

林正英,胃癌能活多久,爆丸小子-uwinapp_u赢app_u赢客户端

北面,培训,通-uwinapp_u赢app_u赢客户端

卡地亚官网,皆大欢喜,geography-uwinapp_u赢app_u赢客户端

文章归档